关于自建代理的一些问题
关于自建代理的一些问题
气笑了,最近搭建了一个垃圾线路的节点,不过有一说一,wap的服务器是真他妈便宜,一个月才2刀,一年竟然只有10刀,虽然说线路很垃圾,VLESS协议在晚高峰时段竟然只能跑到5Mbps,这着实有点少了,不过这还是不能阻止我做梦,要是我能够搞几个vps,然后加上歇斯底里(Hysteria)的协议,每个在晚高峰能跑大概200Mbps,一台机器三个人用,然后卖出去10元一个月,岂不美哉🤓👆
说回正题,刚用s-ui建好节点之后(话说3x-面板似乎不支持sing-box,本地V2rayN和V2rayN)(应该也是配置问题,协议一样怎么可能会不行😂),他妈的电脑端的V2ragN和手机版的V2rayNG都是可以正常上网的,但是我是使用box模块部署的sing-box,这样只会启动一个核心的进程,内存占用率最低,且还能使用Tproxy和eBPF入站,eBPF分流啊,ipset分流啊,对于在核心里边分流的cpu开销要少的很多。
一开始使用的时候,代理还是很正常的,但是突然间代理就失效了,也不能说是失效了,能够访问部分网站,但是却打不开谷歌等等大型网站提示连接已关闭,我就很奇怪,按理来说能够打开部分网站代理就是成功的,这样八成就是配置的问题,我打开s-ui的面板的日志,每当我在谷歌页面刷新一次,日志里就会有一条,一串带有IPv6地址的unreachable的报错,起初我不是很在意,毕竟我的sing-box的配置文件里dns的strategy设为了prefer_ipv4(这边在偷偷吐槽一下sing-box又改配置了,现在这个字段都要删了),按理来说,sing-box有个特性,会让IPv6和IPv4同时发起连接,哪个快就会优先连哪个,如果IPv6访问失败的话会继续IPv4的连接,可是事实立刻打了我的脸,我排查了半天配置依旧无果,我还以为sing-box连接不上是因为我学艺不精配置写错了,然我尝试着关掉IPv6,诶,您猜怎么着,好了!😵
不知道其他机场是怎么调的,我为啥不能够阻断IPv6的连接啊,明明我在服务端设置了规则,阻断IPv6连接,可是依旧没有什么鸟用,还是需要我在客户端手动关闭IPv6,才能正常上网。
后续,搞好了这个问题,我还发现了s-ui不支持Hysteria在设置sni伪装的时候,设置证书指纹,我翻看了issue,开发者说是增加了这个功能,但是我找来找去没看到,只有在Hysteria的入站客户端设置里的多域名的tls设置里开启允许不安全的选项后才会跳出来指纹的输入框,不过我配置了之后更新了订阅,并没什么鸟用,证书指纹还是没有被填好,也不知道是不是我开启的方式不对,只能静等更新了。